Zephyr Scale is not accessible when using Firefox
Incident Report for Zephyr Scale
Postmortem

Due to DNS changes, users using certain browsers with DNS caching features could not load the application anymore. This issue affected existing Zephyr Scale users who were using Firefox with DNS caching enabled.

Firefox was the only browser identified to present this issue and its standard configuration for invalidating the DNS cache is one hour. After the Firefox cache has been invalidated, Zephyr Scale was again accessible to all users.

The issue started around 1:30 pm BST and we got confirmation that it had been fixed about an hour later.

Posted Oct 20, 2021 - 15:23 UTC

Resolved
The system has been operational again over the last ~2h.
Posted Oct 20, 2021 - 15:17 UTC
Monitoring
The root cause has been identified. The error was caused by a change that caused browsers to point to wrong IP addresses if DNS cache was enabled. Google Chrome wasn't affected. Firefox should be back to normal in a few minutes when an hour has passed from the time the problem was detected.

If you are using Firefox and are still affected by this problem, please clear your DNS cache using the instructions below:
1) Type in your Firefox browser URL bar: about:networking#dns
2) Select "Clear DNS cache"
Posted Oct 20, 2021 - 13:31 UTC
Investigating
We identified an issue with a change possibly related to HTTPS certificates that are blocking some users from accessing Zephyr Scale when using Firefox. If you have been affected by this issue, please use Google Chrome as a temporary workaround so that your work is not interrupted.

We'll post updates very soon.
Posted Oct 20, 2021 - 13:11 UTC
This incident affected: Zephyr Scale Cloud.