Zephyr Scale is inaccessible via UI
Incident Report for Zephyr Scale
Resolved
This incident has been resolved.
Posted Feb 24, 2023 - 11:58 UTC
Investigating
We are currently investigating this issue.
Posted Feb 24, 2023 - 11:42 UTC
This incident affected: Zephyr Scale Cloud.